Back to overview
Degraded

Partial outage

May 26, 2026 at 11:39pm UTC
Affected services
Pages server

Resolved
May 27, 2026 at 12:35am UTC

We have identified the problem as an incorrect MTU setting on a route towards our anycast provider. The issue should be resolved.

Created
May 26, 2026 at 11:39pm UTC

We're seeing additional reports of unavailability in certain regions and investigating the problem.